[Android] Device Not Compatible

The Curse Mobile App for Android runs on 4.1 (Jelly Bean) and up.  However, sometimes a user may run into the issue of the Google Play Store saying that their device is not compatible.  If this is the case you will see the error:

Your device isn't compatible with this version.

or something like this image.

Cache and Data

One of the first things you can try is clearing the cache and data from your Google Play Store.

Start by going to your phone's Settings.  Depending on your device and the version of Android you are running - how to get here may be different.

For Samsung users, you should be able to pull down from the top of the screen and tap on the cog wheel.

If you don't have the pull-down feature tap on your Apps, which is usually located in the lower app bar.

Then you just need to locate the Settings app.

Once in the Settings locate your Applications manager. Depending on your device and the version of Android you are running this may be located or labeled differently.  Such as Nexus calls it Apps.

In older Android OS versions on Samsung, you will find the Application manager under the Applications section.

On many Nexus phones it may just be called Apps.

On newer versions of Samsung you can find it under Applications.

Once you have located the Application manager section you should see a list of the apps installed on your phone. Locate the Google Play Store app.

Then tap on the Storage option. 

Next, tap on CLEAR DATA and CLEAR CACHE, and confirm by tapping on OK. 

Note: You may only need to clear data, which may clear the cache as well. 

If you have any updates for the Google Play Store uninstall those as well.

Now reboot your phone, then re-add your Google account and let the Play Store re-update.